<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US" xml:lang="en-US">
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">
<title>Residents reflect on moon landing anniversary - Lake Okeechobee News | Lake Okeechobee News</title>
<link rel="profile" href="https://gmpg.org/xfn/11" />
<!-- <link rel="stylesheet" type="text/css" media="all" href="https://lakeokeechobeenews.com/wp-content/themes/newswire/style.css" /> -->
<link rel="alternate" type="application/rss+xml" title="Lake Okeechobee News RSS Feed" href="https://lakeokeechobeenews.com/feed/" />
<link rel="alternate" type="application/atom+xml" title="Lake Okeechobee News Atom Feed" href="https://lakeokeechobeenews.com/feed/atom/" />
<link rel="pingback" href="https://lakeokeechobeenews.com/xmlrpc.php" />
<!-- <link rel="stylesheet" type="text/css" href="https://lakeokeechobeenews.com/wp-content/themes/newswire/colors/default.css" /> -->
<!-- <link rel="stylesheet" type="text/css" href="https://lakeokeechobeenews.com/wp-content/themes/newswire/css/media-queries.css" /> -->
<!-- <link rel="stylesheet" type="text/css" href="https://lakeokeechobeenews.com/wp-content/themes/newswire/custom.css" /> -->
<link rel="stylesheet" type="text/css" href="//lakeokeechobeenews.com/wp-content/cache/wpfc-minified/k29xeu2t/g0w0c.css" media="all"/>
<!--[if lt IE 9]>
<script src="https://css3-mediaqueries-js.googlecode.com/svn/trunk/css3-mediaqueries.js"></script>
<![endif]-->
<!-- This site is optimized with the Yoast SEO plugin v11.6 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://lakeokeechobeenews.com/community-news/residents-reflect-on-moon-landing-anniversary/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Residents reflect on moon landing anniversary - Lake Okeechobee News" />
<meta property="og:description" content="OKEECHOBEE — Fifty years ago on July 24 astronauts aboard Apollo 11 returned to Earth by splashing down in the north Pacific Ocean after becoming the first human beings to walk to the surface of the Moon. It’s estimated that over 600 million people across the globe watched the events of the Apollo 11 mission, &hellip;" />
<meta property="og:url" content="https://lakeokeechobeenews.com/community-news/residents-reflect-on-moon-landing-anniversary/" />
<meta property="og:site_name" content="Lake Okeechobee News" />
<meta property="article:publisher" content="http://www.facebook.com/okeechobeenews" />
<meta property="article:tag" content="Featured" />
<meta property="article:tag" content="moon" />
<meta property="article:section" content="Community News" />
<meta property="article:published_time" content="2019-07-21T17:45:28+00:00" />
<meta property="article:modified_time" content="2019-07-21T17:42:57+00:00" />
<meta property="og:updated_time" content="2019-07-21T17:42:57+00:00" />
<meta property="og:image" content="https://lakeokeechobeenews.com/wp-content/uploads/2019/07/cropped-Reflections-on-moon-1.jpg" />
<meta property="og:image:secure_url" content="https://lakeokeechobeenews.com/wp-content/uploads/2019/07/cropped-Reflections-on-moon-1.jpg" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="337" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="OKEECHOBEE — Fifty years ago on July 24 astronauts aboard Apollo 11 returned to Earth by splashing down in the north Pacific Ocean after becoming the first human beings to walk to the surface of the Moon. It’s estimated that over 600 million people across the globe watched the events of the Apollo 11 mission, [&hellip;]" />
<meta name="twitter:title" content="Residents reflect on moon landing anniversary - Lake Okeechobee News" />
<meta name="twitter:site" content="@OkeechobeeNews" />
<meta name="twitter:image" content="https://lakeokeechobeenews.com/wp-content/uploads/2019/07/cropped-Reflections-on-moon-1.jpg" />
<meta name="twitter:creator" content="@OkeechobeeNews" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://lakeokeechobeenews.com/#website","url":"https://lakeokeechobeenews.com/","name":"Lake Okeechobee News","potentialAction":{"@type":"SearchAction","target":"https://lakeokeechobeenews.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://lakeokeechobeenews.com/community-news/residents-reflect-on-moon-landing-anniversary/#primaryimage","url":"https://lakeokeechobeenews.com/wp-content/uploads/2019/07/cropped-Reflections-on-moon-1.jpg","width":600,"height":337},{"@type":"WebPage","@id":"https://lakeokeechobeenews.com/community-news/residents-reflect-on-moon-landing-anniversary/#webpage","url":"https://lakeokeechobeenews.com/community-news/residents-reflect-on-moon-landing-anniversary/","inLanguage":"en-US","name":"Residents reflect on moon landing anniversary - Lake Okeechobee News","isPartOf":{"@id":"https://lakeokeechobeenews.com/#website"},"primaryImageOfPage":{"@id":"https://lakeokeechobeenews.com/community-news/residents-reflect-on-moon-landing-anniversary/#primaryimage"},"datePublished":"2019-07-21T17:45:28+00:00","dateModified":"2019-07-21T17:42:57+00:00","author":{"@id":"https://lakeokeechobeenews.com/#/schema/person/7faf24030b4f29163876dcd1d39316e0"}},{"@type":["Person"],"@id":"https://lakeokeechobeenews.com/#/schema/person/7faf24030b4f29163876dcd1d39316e0","name":"Nancy Wills","image":{"@type":"ImageObject","@id":"https://lakeokeechobeenews.com/#authorlogo","url":"https://secure.gravatar.com/avatar/cde3e71c5293152c4cb18aa3a9e5c427?s=96&d=mm&r=g","caption":"Nancy Wills"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="text/xml" title="Lake Okeechobee News &raquo; Feed" href="https://lakeokeechobeenews.com/feed/" />
<link rel="alternate" type="text/xml" title="Lake Okeechobee News &raquo; Comments Feed" href="https://lakeokeechobeenews.com/comments/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/lakeokeechobeenews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.2"}};
!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<meta content="/home/okeechobeenews/public_html/wp-content/themes/newswire/style.css v." name="generator"/><style type="text/css">
img.wp-smiley,
img.emoji {
display: inline !important;
border: none !important;
box-shadow: none !important;
height: 1em !important;
width: 1em !important;
margin: 0 .07em !important;
vertical-align: -0.1em !important;
background: none !important;
padding: 0 !important;
}
</style>
<!-- <link rel='stylesheet' id='shortcodes-css'  href='https://lakeokeechobeenews.com/wp-content/themes/newswire/functions/shortcodes/shortcodes.css?ver=5.2.2' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='wp-block-library-css'  href='https://lakeokeechobeenews.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.2' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='tablepress-default-css'  href='https://lakeokeechobeenews.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.9.2' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='__EPYT__style-css'  href='https://lakeokeechobeenews.com/wp-content/plugins/youtube-embed-plus/styles/ytprefs.min.css?ver=13.1' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//lakeokeechobeenews.com/wp-content/cache/wpfc-minified/6o5hn97c/g0w0c.css" media="all"/>
<style id='__EPYT__style-inline-css' type='text/css'>
.epyt-gallery-thumb {
width: 33.333%;
}
</style>
<!-- <link rel='stylesheet' id='jetpack_css-css'  href='https://lakeokeechobeenews.com/wp-content/plugins/jetpack/css/jetpack.css?ver=7.5.3' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//lakeokeechobeenews.com/wp-content/cache/wpfc-minified/e2i6ppxx/g0w0c.css" media="all"/>
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js?ver=1.10.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script src='//lakeokeechobeenews.com/wp-content/cache/wpfc-minified/lnt5s8c9/g0w0j.js' type="text/javascript"></script>
<!-- <script type='text/javascript' src='https://lakeokeechobeenews.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20190204'></script> -->
<script type='text/javascript'>
/* <![CDATA[ */
var _EPYT_ = {"ajaxurl":"https:\/\/lakeokeechobeenews.com\/wp-admin\/admin-ajax.php","security":"cdccfaa403","gallery_scrolloffset":"20","eppathtoscripts":"https:\/\/lakeokeechobeenews.com\/wp-content\/plugins\/youtube-embed-plus\/scripts\/","eppath":"https:\/\/lakeokeechobeenews.com\/wp-content\/plugins\/youtube-embed-plus\/","epresponsiveselector":"[\"iframe.__youtube_prefs_widget__\"]","epdovol":"1","version":"13.1","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]","ajax_compat":"","ytapi_load":"light","stopMobileBuffer":"1","vi_active":"","vi_js_posttypes":[]};
/* ]]> */
</script>
<script src='//lakeokeechobeenews.com/wp-content/cache/wpfc-minified/efdmg7m0/g0w0c.js' type="text/javascript"></script>
<!-- <script type='text/javascript' src='https://lakeokeechobeenews.com/wp-content/plugins/youtube-embed-plus/scripts/ytprefs.min.js?ver=13.1'></script> -->
<!-- <script type='text/javascript' src='https://lakeokeechobeenews.com/wp-content/themes/newswire/functions/shortcodes/shortcodes.js?ver=1.0.0'></script> -->
<!-- <script type='text/javascript' src='https://lakeokeechobeenews.com/wp-content/themes/newswire/includes/js/jquery-ui-1.8.5.custom.min.js?ver=1.8.5'></script> -->
<!-- <script type='text/javascript' src='https://lakeokeechobeenews.com/wp-content/themes/newswire/includes/js/superfish.js?ver=1.4.2'></script> -->
<!-- <script type='text/javascript' src='https://lakeokeechobeenews.com/wp-content/themes/newswire/includes/js/custom.js?ver=1.4.2'></script> -->
<!-- <script type='text/javascript' src='https://lakeokeechobeenews.com/wp-content/themes/newswire/includes/js/scrolltop.js?ver=1.0'></script> -->
<script type='text/javascript' src='https://platform.twitter.com/widgets.js?ver=1.0'></script>
<script type='text/javascript' src='https://apis.google.com/js/plusone.js?ver=1.0'></script>
<link rel='https://api.w.org/' href='https://lakeokeechobeenews.com/wp-json/' />
<meta name="generator" content="WordPress 5.2.2" />
<link rel='shortlink' href='https://wp.me/p7Bxc0-5P3' />
<link rel="alternate" type="application/json+oembed" href="https://lakeokeechobeenews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flakeokeechobeenews.com%2Fcommunity-news%2Fresidents-reflect-on-moon-landing-anniversary%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://lakeokeechobeenews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flakeokeechobeenews.com%2Fcommunity-news%2Fresidents-reflect-on-moon-landing-anniversary%2F&#038;format=xml" />
<meta property="fb:app_id" content="103764836632626"/>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel="shortcut icon" href="https://okeechobeenews.net/wp-content/uploads/2015/09/arizona-favicon.jpg" /><!-- Custom Styling -->
<style type="text/css">
.entry-content p {
font-size: 16px;
line-height: 25px;
}
.entry-content ul {
font-size: 16px;
line-height: 25px;
}
.entry-content ul li {
padding: 2px 20px 15px 15px;
}
.entry-tags::before {
border-top: 1px solid #ddd;
content: "";
display: block;
margin-bottom: 1em;
min-width: 30px;
width: 100%;
}
body {
font: 13px/19px Georgia, Arial, "Lucida Grande", sans-serif;
}
.wp-caption p.wp-caption-text {
font-size: 12px;
line-height: 15px;
color: #a9a9a9;
font-family: helvetica;
padding: 2px 4px 4px 6px;
text-align: left;
}
.wp-block-image figcaption {
text-align: left;
font-size: 11px;
}
</style>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>
<link rel="amphtml" href="https://lakeokeechobeenews.com/community-news/residents-reflect-on-moon-landing-anniversary/amp/"><!-- custom CSS -->
<link rel="stylesheet" type="text/css" href="https://delawarestatenews.net/inicustom.css"/>
<!-- Doubleclick -->
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
</script>
<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/83779297/fl-leaderboard-01', [728, 90], 'div-gpt-ad-1372687360134-0').addService(googletag.pubads());
googletag.defineSlot('/83779297/fl-leaderboard-02', [728, 90], 'div-gpt-ad-1520451498203-0').addService(googletag.pubads());
googletag.defineSlot('/83779297/fl-mediumrectangle-01', [300, 250], 'div-gpt-ad-1372687360134-1').addService(googletag.pubads());
googletag.defineSlot('/83779297/fl-mediumrectangle-02', [300, 250], 'div-gpt-ad-1372687360134-2').addService(googletag.pubads());
googletag.defineSlot('/83779297/fl-mediumrectangle-03', [300, 250], 'div-gpt-ad-1372687360134-3').addService(googletag.pubads());
googletag.defineSlot('/83779297/fl-mobile-adhesion-01', [1, 1], 'div-gpt-ad-1560453041135-0').addService(googletag.pubads());
googletag.defineSlot('/83779297/fl-pencilpush-01', [1, 1], 'div-gpt-ad-1560453600273-0').addService(googletag.pubads());
googletag.defineSlot('/83779297/fl-mobilepull-01', [1, 1], 'div-gpt-ad-1560453639764-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.pubads().setTargeting('community', ['Okeechobee']);
googletag.enableServices();
});
</script>
<!-- /83779297/fl-mobile-adhesion-01 -->
<div id='div-gpt-ad-1560453041135-0' style='height:1px; width:1px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1560453041135-0'); });
</script>
</div>
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-64247352-1', 'auto');
ga('send', 'pageview');
</script>			<style type="text/css" id="wp-custom-css">
/*
You can add your own CSS here.
Click the help icon above to learn more.
*/
@media only screen and (max-width: 767px) {
.footer-categories {
display: block;
height: auto;
margin-bottom: 5px;
}
}
.contest-box {background-color:midnightblue; color: white; padding:10px; margin-bottom:30px;}
.contest-button {background-color: white; border: none; color: midnightblue; padding: 12px; text-align: left; text-decoration: none; display: inline-block; font-size: 16px;}
.contest-button a:link {color:midnightblue; text-decoration:none;}
.contest-button a:visited {color:midnightblue; text-decoration:none;}
.contest-button a:hover {color:midnightblue; text-decoration:none;}
.contest-button a:active {color:midnightblue; text-decoration:none;}			</style>
<style type='text/css'>
.ai-viewport-3                { display: none !important;}
.ai-viewport-2                { display: none !important;}
.ai-viewport-1                { display: inherit !important;}
.ai-viewport-0                { display: none !important;}
@media (min-width: 768px) and (max-width: 979px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-2                { display: inherit !important;}
}
@media (max-width: 767px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-3                { display: inherit !important;}
}
</style>
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-22385 single-format-standard custom-background unknown">
<div id="wrapper">
<div id="primary-nav">
<ul id="primary-navigation" class="nav"><li id="menu-item-144" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-144"><a href="#">Subscribe</a>
<ul class="sub-menu">
<li id="menu-item-149" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149"><a href="https://diniservices.newscyclecloud.com/cmo_din-c-cmdb-01/subscriber/web/signin.html?siteId=INI">Print Newspaper</a></li>
<li id="menu-item-22" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22"><a href="https://diniservices.newscyclecloud.com/cmo_din-c-cmdb-01/subscriber/web/signin.html?siteId=INI">E-Newspaper</a></li>
<li id="menu-item-17" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17"><a href="https://lakeokeechobeenews.com/enewsletter/">Email Newsletter</a></li>
</ul>
</li>
<li id="menu-item-145" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-145"><a href="#">Reader Services</a>
<ul class="sub-menu">
<li id="menu-item-151" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151"><a href="https://lakeokeechobeenews.com/find/">Find the Okeechobee News</a></li>
<li id="menu-item-152" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-152"><a href="https://diniservices.newscyclecloud.com/cmo_din-c-cmdb-01/subscriber/web/signin.html?siteId=INI">Subscription Center</a></li>
<li id="menu-item-150" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-150"><a href="https://lakeokeechobeenews.com/contact/">Contact Us</a></li>
<li id="menu-item-153" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-153"><a href="http://okeechobeenews.fl.newsmemory.com/marketplace.php">Print  Edition Ads</a></li>
<li id="menu-item-724" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-724"><a href="http://lakeokeechobeenews.newsbank.com/">Online Print Archive</a></li>
</ul>
</li>
<li id="menu-item-148" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-148"><a href="https://floridaclassifieds.newszap.com/">Classifieds</a></li>
<li id="menu-item-192" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-192"><a href="https://www.legacy.com/obituaries/newszapfl/">Obits</a></li>
<li id="menu-item-146" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-146"><a href="http://lakeokeechobeerealestate.fl.newsmemory.com/">Real Estate</a></li>
<li id="menu-item-147" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-147"><a href="https://floridaclassifieds.newszap.com/classifieds/other/">Legal Notices</a></li>
<li id="menu-item-17354" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17354"><a href="http://sections.iniusa.org/index.php?sortby=paper&#038;paper=Okeechobee+News">Special Sections</a></li>
</ul>		<form method="get" id="searchform" action="https://lakeokeechobeenews.com">
<fieldset>
<input type="text" name="s" id="s" placeholder="Search" />
</fieldset>
</form>
</div><!-- #primary-nav -->
<div id="header">
<a href="https://lakeokeechobeenews.com"><img src="https://lakeokeechobeenews.com/wp-content/uploads/2018/09/LakeOkeeNewsweb.jpg" alt="Lake Okeechobee News" id="logo"/></a>
<div class='header-ad'><div class='code-block code-block-1' style='margin: 8px 0; clear: both;'>
<!-- fl-leaderboard-01 -->
<div id='div-gpt-ad-1372687360134-0' style='width:728px; height:90px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1372687360134-0'); });
</script>
</div></div>
</div>		<a class="button-menu" id="toggle" href="#"></a>			
<div class="clear"></div> 
</div><!-- #header-->
<div class="spacer_15"></div>
<!-- /83779297/fl-pencilpush-01 -->
<div id='div-gpt-ad-1560453600273-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1560453600273-0'); });
</script>
</div>
<div id="secondary-nav">
<ul id="secondary-navigation" class="nav"><li id="menu-item-2131" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2131"><a href="#">News</a>
<ul class="sub-menu">
<li id="menu-item-193" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-193"><a href="https://lakeokeechobeenews.com/section/business/">Business</a></li>
<li id="menu-item-44" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44"><a href="https://lakeokeechobeenews.com/section/government/">Government</a></li>
<li id="menu-item-45" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-45"><a href="https://lakeokeechobeenews.com/section/health/">Health</a></li>
<li id="menu-item-46" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46"><a href="https://lakeokeechobeenews.com/section/lake-okeechobee/">Lake Okeechobee</a></li>
<li id="menu-item-19860" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19860"><a href="https://lakeokeechobeenews.com/section/veterans/">Veterans Stories</a></li>
</ul>
</li>
<li id="menu-item-726" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-726"><a href="https://lakeokeechobeenews.com/section/community-news/">Community</a></li>
<li id="menu-item-32" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32"><a href="https://lakeokeechobeenews.com/section/crime/">Crime</a></li>
<li id="menu-item-35" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35"><a href="https://lakeokeechobeenews.com/section/schools/">Schools</a></li>
<li id="menu-item-48" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48"><a href="https://lakeokeechobeenews.com/section/sports/">Sports</a></li>
<li id="menu-item-43" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43"><a href="https://lakeokeechobeenews.com/section/entertainment/">Entertainment</a></li>
<li id="menu-item-47" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47"><a href="https://lakeokeechobeenews.com/section/opinion/">Opinion</a></li>
<li id="menu-item-2130" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2130"><a href="https://lakeokeechobeenews.com/churchdirectory/">Churches</a></li>
<li id="menu-item-17364" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-17364"><a href="#">Your Town</a>
<ul class="sub-menu">
<li id="menu-item-17365" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17365"><a href="https://lakeokeechobeenews.com/community/belle-glade/">Belle Glade</a></li>
<li id="menu-item-17366" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17366"><a href="https://lakeokeechobeenews.com/community/buckhead-ridge/">Buckhead Ridge</a></li>
<li id="menu-item-17367" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17367"><a href="https://lakeokeechobeenews.com/community/canal-point/">Canal Point</a></li>
<li id="menu-item-17368" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17368"><a href="https://lakeokeechobeenews.com/community/clewiston/">Clewiston</a></li>
<li id="menu-item-17369" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17369"><a href="https://lakeokeechobeenews.com/community/lakeport/">Lakeport</a></li>
<li id="menu-item-17370" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17370"><a href="https://lakeokeechobeenews.com/community/moore-haven/">Moore Haven</a></li>
<li id="menu-item-17371" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17371"><a href="https://lakeokeechobeenews.com/community/okeechobee/">Okeechobee</a></li>
<li id="menu-item-17372" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17372"><a href="https://lakeokeechobeenews.com/community/pahokee/">Pahokee</a></li>
<li id="menu-item-17373" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17373"><a href="https://lakeokeechobeenews.com/community/south-bay/">South Bay</a></li>
</ul>
</li>
</ul>	</div><!-- #secondary-nav -->
<div id="main">
<div id="content">
<div id="breadcrumbs">
<a href="https://lakeokeechobeenews.com">Home</a> 
<a href="https://lakeokeechobeenews.com/section/community-news/">Community News</a> <span class="entry-title">Residents reflect on moon landing anniversary</span>				</div><!--end #breadcrumbs-->
<div id="post-22385" class="post-22385 post type-post status-publish format-standard has-post-thumbnail hentry category-community-news tag-featured tag-moon Authors-richard-marion Communities-okeechobee Newsletters-okeechobee">
<!-- Go to www.addthis.com/dashboard to customize your tools -->
<div class="addthis_sharing_toolbox"></div>
<h1 class="entry-title">Residents reflect on moon landing anniversary</h1>  
<div class="entry-meta">
<span class="entry-date">Jul 21st, 2019</span> &middot; by  <a href="https://lakeokeechobeenews.com/topic/richard-marion/" rel="tag">Richard Marion</a>  &middot;<span class="entry-comment"> Comments: <fb:comments-count href="https://lakeokeechobeenews.com/community-news/residents-reflect-on-moon-landing-anniversary/"></fb:comments-count></span>
</div><!-- .entry-meta -->
<div class="entry-content">
<p>OKEECHOBEE — Fifty years ago on July 24 astronauts aboard Apollo 11 returned to Earth by splashing down in the north Pacific Ocean after becoming the first human beings to walk to the surface of the Moon.</p>
<p>It’s estimated that over 600 million people across the globe watched the events of the Apollo 11 mission, from the lift-off that happened 80 miles north of Okeechobee at Cape Canaveral to Neil Armstrong taking his first step onto the lunar surface.</p>
<figure class="wp-block-image"><img src="https://lakeokeechobeenews.com/wp-content/uploads/2019/07/Reflections-on-moon-1.jpg" alt="" class="wp-image-22386" srcset="https://lakeokeechobeenews.com/wp-content/uploads/2019/07/Reflections-on-moon-1.jpg 600w, https://lakeokeechobeenews.com/wp-content/uploads/2019/07/Reflections-on-moon-1-300x296.jpg 300w, https://lakeokeechobeenews.com/wp-content/uploads/2019/07/Reflections-on-moon-1-80x80.jpg 80w, https://lakeokeechobeenews.com/wp-content/uploads/2019/07/Reflections-on-moon-1-100x100.jpg 100w" sizes="(max-width: 600px) 100vw, 600px" /><figcaption>Special to the Lake Okeechobee News/NASA<br> Astronaut Buzz Aldrin, lunar module pilot of the first lunar landing mission, poses for a photograph beside the deployed United States flag during an Apollo 11 extravehicular activity (EVA) on the lunar surface on July 20, 1969.</figcaption></figure>
<p>Okeechobee County Commissioner Bryant Culpepper was one of the many who made the trip to Cape Canaveral in 1969 to watch the Saturn V rocket take off from the Kennedy Space Center.</p>
<p>“I remember that like it happened yesterday,” said Commissioner Culpepper of the Apollo 11 launch. “Every time they had a big launch, my family would jump in the old ’49 Mercury wagon to go watch it. When you’re there you actually feel the concussion and the ground shaking from the Atlas booster going off. It was unbelievable. That sound and that feeling will be with me the rest of my life.”</p>
<div class="wp-block-image"><figure class="aligncenter"><img src="https://lakeokeechobeenews.com/wp-content/uploads/2019/07/Reflections-on-moon-2.jpg" alt="" class="wp-image-22387" srcset="https://lakeokeechobeenews.com/wp-content/uploads/2019/07/Reflections-on-moon-2.jpg 470w, https://lakeokeechobeenews.com/wp-content/uploads/2019/07/Reflections-on-moon-2-176x300.jpg 176w" sizes="(max-width: 470px) 100vw, 470px" /><figcaption>Special to the Lake Okeechobee News/NASA<br> Apollo 11 is launched from NASA’s Kennedy Space Center in Cape Canaveral on July 16, 1969.</figcaption></figure></div>
<p>Commissioner Culpepper was 20 years old when the Apollo mission launched and says that throughout his life he has always tried follow and keep up with what missions NASA was working on.</p>
<p>“What blew me away at the time is how mankind could go from the first flight in 1903 to landing on the Moon in 1969,” explained Commissioner Culpepper. “I couldn’t conceive of that as a young person, it was stunning to me. We take it for granted now, but to imagine people actually walking on the Moon was almost inconceivable. It was exciting to be able to live through that time period.”</p>
<p>Okeechobee Mayor Dowling Watford also remembers the Apollo 11 mission well.</p>
<p>“The Moon landing was one of those ‘I remember exactly where I was’ moments,” Mayor Watford said. “Everyone was glued to our black and white TVs with great anticipation and excitement. It was a great moment when we heard the words ‘the eagle has landed’ and then ‘one small step for man, one giant leap for mankind.’ We knew then the mission was a success and we had beat the Russians to the Moon.”</p>
<figure class="wp-block-image"><img src="https://lakeokeechobeenews.com/wp-content/uploads/2019/07/Reflections-on-moon-3.jpg" alt="" class="wp-image-22388" srcset="https://lakeokeechobeenews.com/wp-content/uploads/2019/07/Reflections-on-moon-3.jpg 600w, https://lakeokeechobeenews.com/wp-content/uploads/2019/07/Reflections-on-moon-3-300x172.jpg 300w" sizes="(max-width: 600px) 100vw, 600px" /><figcaption>Special to the Lake Okeechobee News/NASA<br> Former President Lyndon B. Johnson and then-current Vice President Spiro Agnew watch the launch of Apollo 11, which lifted off from Pad 39A at the Kennedy Space Center at 9:32 a.m. on July 16, 1969. Then 20-year old future Okeechobee County Commissioner Bryant Culpepper was also at Cape Canaveral that day, but he probably didn’t have as good of a seat as President Johnson.</figcaption></figure>
<p>Currently NASA has plans to return to the Moon in 2024 under a program they’ve named ‘Artemis.’ In Greek mythology Artemis was the twin sister of Apollo.</p>
<p>NASA has announced the goal of the program is to land the first woman and the next man on the lunar south pole region. The hope is that the Artemis program will be the first step towards the long-term goal of establishing a sustainable presence on the Moon.</p>
<p>“I think seeing something like that light up the sky pushed a lot of kids to go into scientific fields,” said Commissioner Culpepper of the NASA launches. “We’ve kind of lost that now. Kids today are not getting that motivation to be able to drive themselves to a profession that has so much impact on the world.”</p>
<!-- Author Description -->
<p><em>Richard Marion is a staff writer and photographer at Lake Okeechobee News and can be reached at <a href="mailto:rmarion@newszap.com">rmarion@newszap.com</a>.</em></p><div class="spacer_10"></div>		
<div class="entry-tags"><span>Tags:</span><a href="https://lakeokeechobeenews.com/tag/featured/" rel="tag">Featured</a> &middot; <a href="https://lakeokeechobeenews.com/tag/moon/" rel="tag">moon</a></div>		  		<div class="clear"></div>
</div><!--end .entry-->
<?php echo category_description(); ?>	
</div><!-- #post-22385 -->
<div id='jp-relatedposts' class='jp-relatedposts' >
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>			
<div id="jp-relatedposts" class="jp-relatedposts" style="display: block;">
<h3 class="jp-relatedposts-headline">
<em>Newsletter</em>
</h3>
</div>
<!-- Begin MailChimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; width:100%;}
/* Add your own MailChimp form style overrides in your site stylesheet or in this style block.
We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="//okeechobeenews.us8.list-manage.com/subscribe/post?u=c0b15575bb95f493b0c78850b&amp;id=23edd09a78" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL">Subscribe to the Okeechobee News email newsletter</label>
<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>
<div class="mc-field-group input-group" style="display:none">
<ul><li><input type="checkbox" value="1" name="group[8569][1]" id="mce-group[8569]-8569-0" checked><label for="mce-group[8569]-8569-0">Lake Okeechobee - 3X a Week</label></li>
<li><input type="checkbox" value="2" name="group[8569][2]" id="mce-group[8569]-8569-1"><label for="mce-group[8569]-8569-1">Clewiston News</label></li>
<li><input type="checkbox" value="4" name="group[8569][4]" id="mce-group[8569]-8569-2"><label for="mce-group[8569]-8569-2">Glades County Democrat</label></li>
<li><input type="checkbox" value="8" name="group[8569][8]" id="mce-group[8569]-8569-3"><label for="mce-group[8569]-8569-3">Belle Glade Sun</label></li>
</ul>
</div>
<!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_c0b15575bb95f493b0c78850b_23edd09a78" tabindex="-1" value=""></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</div>
</form>
</div>
<!--End mc_embed_signup-->
<div id="jp-relatedposts" class="jp-relatedposts" style="display: block;">
<h3 class="jp-relatedposts-headline">
<em>Comments</em>
</h3>
</div>
<p style="font-size:14px">
You are encouraged to leave relevant comments but engaging in personal attacks, threats, online bullying or commercial spam will not be allowed. All comments should remain within the bounds of fair play and civility. (You can disagree with others courteously, without being disagreeable.) Feel free to express yourself but keep an open mind toward finding value in what others say. To report abuse or spam, click the X in the upper right corner of the comment box.</p>
<div id="wpdevar_comment_1" style="width:100%;text-align:left;">
<span style="padding: 10px;font-size:22px;font-family:monospace;color:#ffffff;">Facebook Comment</span>
<div class="fb-comments" data-href="https://lakeokeechobeenews.com/community-news/residents-reflect-on-moon-landing-anniversary/" data-order-by="social" data-numposts="3" data-width="100%" style="display:block;"></div></div><style>#wpdevar_comment_1 span,#wpdevar_comment_1 iframe{width:100% !important;}</style>
</div><!--end #content-->
<div id="sidebar">
<div id="ai_widget-2" class="widget ai_widget"><div class='code-block code-block-4' style='margin: 8px 0; clear: both;'>
<!-- ROS top rectangle -->
<!-- fl-mediumrectangle-02 -->
<center>
advertisement
</center>
<div id='div-gpt-ad-1372687360134-2' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1372687360134-2'); });
</script>
</div></div>
</div><div id="text-2" class="widget widget_text"><h3 class="widget-title">Print Edition</h3>			<div class="textwidget"><div class="inifrontpagewdg-wrapper">
<div class="spacer_10"></div>
<a href="http://okeechobeenews.fl.newsmemory.com/"><img src="https://okeechobeenews-fl.newsmemory.com/getprima.php" alt="Okeechobee News front page"/></a>
<div class="spacer_10"></div>
The Lake Okeechobee News is published every Wednesday, Friday, and Sunday. You can <a href="https://okeechobeenews.net/find/" title="Find the Newspaper">find it in retail outlets</a> throughout the Okeechobee area, or <a href="https://diniservices.newscyclecloud.com/cmo_din-c-cmdb-01/subscriber/web/signin.html?siteId=INI" title="subscribe">subscribe</a> to our print newspaper or our e-newspaper, a digital replica of the print edition.
</div></div>
</div>		
<div class="tj_widget_social">
<div class="social-icons">
<ul>
<li class="icon-rss"><a href="/feed/">Subscribe to<br />RSS</a></li>
<li class="icon-twitter"><a href="http://twitter.com/OkeechobeeNews">Follow on<br />Twitter</a></li>
<li class="icon-facebook"><a href="http://www.facebook.com/okeechobeenews">Join us on<br />Facebook</a></li>				
<li class="icon-enews"><a href="/enewsletter/">Sign-up for<br />Newsletter</a></li>
</ul>
<div class="clear"></div>
</div>
</div><!-- .tj_widget_social -->
<div id="custom_html-2" class="widget_text widget widget_custom_html"><h3 class="widget-title">Okeechobee Weather</h3><div class="textwidget custom-html-widget"><a href="/weather/"><img src="https://okeechobeenews.net/wp-content/uploads/2017/08/todaysweatherfinal.png"></a></div></div><div id="ai_widget-3" class="widget ai_widget"><div class='code-block code-block-5' style='margin: 8px 0; clear: both;'>
<!-- ROS bottom rectangle -->
<!-- fl-mediumrectangle-03 -->
<center>
advertisement
</center>
<div id='div-gpt-ad-1372687360134-3' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1372687360134-3'); });
</script>
</div></div>
</div></div><!-- #sidebar -->
	</div><!-- #main -->
<div class="clear"></div>
<div class="footer-categories">
<ul>
<li><div class="menu-footer-container"><ul id="menu-footer" class="sf-menu"><li id="menu-item-6652" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6652"><a href="https://lakeokeechobeenews.com/about/">About Us</a></li>
<li id="menu-item-178" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-178"><a href="https://lakeokeechobeenews.com/contact/">Contact Us</a></li>
<li id="menu-item-10874" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10874"><a href="https://newszap.com/#privacy">Privacy Policy</a></li>
<li id="menu-item-155" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-155"><a href="http://sections.iniusa.org/index.php?sortby=paper&#038;paper=Okeechobee+News">Special Sections</a></li>
</ul></div></a></li>
</ul>
<div class="clear"></div>
</div><!-- .footer-categories -->
<div class='code-block code-block-2 ai-viewport-1' style='margin: 8px 0; clear: both;'>
<center>
<div class="spacer_10"></div>
<!-- /83779297/fl-leaderboard-02 -->
<div id='div-gpt-ad-1520451498203-0' style='height:90px; width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1520451498203-0'); });
</script>
</div>
</center></div>
<div class="copyright">
<p>&copy; 2019 <a href="/about/">Independent Newsmedia Inc. USA</a>. All rights reserved.</p>
<p><a href="http://www.theme-junkie.com">WordPress Theme</a> designed by <a href="http://www.theme-junkie.com">Theme Junkie</a></p>
</div><!-- .copyright -->
<!-- /83779297/fl-mobilepull-01 -->
<div id='div-gpt-ad-1560453639764-0' style='height:1px; width:1px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1560453639764-0'); });
</script>
</div>
<div class="clear"></div>
</div><!-- #wrapper -->
<a id="back-to-top" href="#"></a>
<div id="fb-root"></div>
<script>(function(d, s, id) {
var js, fjs = d.getElementsByTagName(s)[0];
if (d.getElementById(id)) return;
js = d.createElement(s); js.id = id;
js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=103764836632626&version=v2.3";
fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>	
<script>try{ mc4wp.forms.on('submitted', function() { if(grecaptcha) { grecaptcha.reset(); } }); } catch(e) {}</script>	<div style="display:none">
</div>
<!-- Go to www.addthis.com/dashboard to customize your tools -->
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-50786cb629e532c2" async="async"></script><!-- <link rel='stylesheet' id='dashicons-css'  href='https://lakeokeechobeenews.com/wp-includes/css/dashicons.min.css?ver=5.2.2' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='thickbox-css'  href='https://lakeokeechobeenews.com/wp-includes/js/thickbox/thickbox.css?ver=5.2.2' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//lakeokeechobeenews.com/wp-content/cache/wpfc-minified/eeuql8ew/g0w0c.css" media="all"/>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201930'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2019Julaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://lakeokeechobeenews.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=5.2.2'></script>
<script type='text/javascript' src='https://lakeokeechobeenews.com/wp-content/plugins/youtube-embed-plus/scripts/fitvids.min.js?ver=13.1'></script>
<script type='text/javascript' src='https://lakeokeechobeenews.com/wp-includes/js/wp-embed.min.js?ver=5.2.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/lakeokeechobeenews.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://lakeokeechobeenews.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
</body>
</html><!-- WP Fastest Cache file was created in 1.7294170856476 seconds, on 21-07-19 21:49:37 --><!-- via php -->